Mailed Database UpdateMailed Update, Full Database

Notice: This version of the database, version 6.3 (April 2017), requires that your bar code reader is either an i.d. mate Galaxy, Quest, Summit, or that it is an i.d. mate Omni with both of the following:

  • Version 3.0 or higher of the firmware. To determine your firmware version, turn on your OMNI. After the intro, press and release the Mode and Record buttons simultaneously. If the firmware version is lower than 3.0, you will need to send your OMNI unit and your CompactFlash card to us at En-Vision America for a V3 upgrade. Please call us at 1-800-890-1180 to learn about your upgrade needs, cost, and to¬†get an RMA number before sending your Omni in.
  • A 2 gigabyte CompactFlash card.

After receiving your database CD, you will need a card reader (not included) for your PC appropriate to your i.d. mate model. The Omni uses a CompactFlash card, and the Summit uses an SD card. The Galaxy and Quest can be connected to your PC via USB cable (Male A to mini B). To update your database, simply replace the BARCODES.DAT file in the root of your device’s memory with the one downloaded from the store.

You may also receive your database update already on a new SD memory card that can be inserted right into your i.d. mate Summit (not available for Omni). In order to use your current custom voice recordings, they will need to be transferred from your current memory card to your new card. You will need a card reader (not included) connected to your PC to accomplish this (see above).

A new product database comes out twice per year, typically in April and October. Please consider the timing of an order for this version of the database.

Price: $50.00
transparent spacer